• Willkommen, Gast!
  • Freitag, 23. August 2019, 14:07:10
Position: Home » Boardsolution » Boardsolution v1.4x » Boardsolution v1.40 Beta » Fehlermeldung
Thema: Fehlermeldung [Seite 1 ]

Kein neuer Beitrag Eddy82 , 26.11.2010, 21:38
Beitrag #1   

IP: n/a
Rang: * * * * * * *
Registrierung: 26.11.2010, 21:18
 

Forum-Gott mit 6 Punkte, 4 Beiträge
Hallo Leute

Bin neu hier und habe direkt ein frage an euch.
Ein bekannter von mir hat mir ein Forum zur Verfügung gestellt (Boardsolution v1.40 Beta2).
Jetzt wollten sich welche Registrinen aber das geht net es kommt immer eine Fehler meldung.


The argument $user_id (value = "0";) has to be an integer and > 0
Call-trace:

/fws/error/handler.php in line 192 [ Method: FWS_Error_Handler::get_error_message() ]
0187 // note that this means that nobody should set error-reporting to 0 because otherwise 0188 //
we would log no error 0189 if((error_reporting() & $no) == 0 || $this->_max_errors()) 0190 return;
0191 0192 echo $this->get_error_message($no,$msg,$file,$line); 0193 $this->_error_count++; 0194 }
0195 0196 /** 0197 * Builds the error-message for the given error including backtrace, if possible.
0198 * Note that this method logs the error, too!
Unknown [ Method: FWS_Error_Handler::handle_error() ]
/fws/helper.php in line 286 [ Function: trigger_error() ]
0281 * @param boolean $die do you want to stop the script? 0282 * @param int $level the
error-level. See E_USER_* 0283 */ 0284 public static function error($message,$die = true,$level =
E_USER_ERROR) 0285 { 0286 trigger_error($message,$level); 0287 if($die) 0288 die(); 0289 } 0290 }
0291 ?>
/fws/helper.php in line 241 [ Method: FWS_Helper::error() ]
0236 default: 0237 FWS_Helper::error('Unknown type: '.$type); 0238 break; 0239 } 0240 0241
FWS_Helper::error($msg); 0242 } 0243 0244 /** 0245 * Builds the string-value of the given value for
#def_error() 0246 * 0247 * @param mixed $val the value
/src/dao/user.php in line 300 [ Method: FWS_Helper::def_error() ]
0295 if(empty($user_email)) 0296 FWS_Helper::def_error('notempty','user_email',$user_email); 0297
if(empty($user_pw)) 0298 FWS_Helper::def_error('notempty','user_pw',$user_pw); 0299 if($user_id !==
null && (!FWS_Helper::is_integer($user_id) || $user_id <= 0)) 0300
FWS_Helper::def_error('intgt0','user_id',$user_id); 0301 0302 $fields = array( 0303
BS_EXPORT_USER_NAME => $user_name, 0304 BS_EXPORT_USER_EMAIL => $user_email, 0305 BS_EXPORT_USER_PW
=> md5($user_pw) 0306 );
/front/src/action/plain/register.php in line 283 [ Method: BS_DAO_User::create() ]
0278 $db->start_transaction(); 0279 0280 // insert the user into the database 0281 $id =
BS_DAO::get_user()->create( 0282
$this->_user_name,$this->_user_email,$this->_user_pw,$this->_user_id 0283 ); 0284
if($this->_user_id !== null) 0285 $this->_user_id = $id; 0286 0287 $time = time(); 0288 0289
$fields = array(
/front/module/register/action_default.php in line 69 [ Method:
BS_Front_Action_Plain_Register::perform_action() ]
0064 $res = $register->check_data(); 0065 if($res != '';) 0066 return
$res; 0067 0068 // perform action 0069 $register->perform_action(); 0070 0071 // finish up 0072
$this->set_action_performed(true); 0073
$this->add_link($locale->lang('forumindex'),BS_URL::get_start_url()); 0074 $this->set_success_msg(
0075 $locale->lang('success_'.BS_ACTION_REGISTER.'_'.$cfg['account_activation'])
/fws/action/performer.php in line 265 [ Method: BS_Front_Action_register_default::perform_action()
]
0260 $this->_listener->before_action_performed($id,$c); 0261 0262
if(isset($this->_add_params[$id])) 0263 $message =
call_user_func_array(array($c,'perform_action'),$this->_add_params[$id]); 0264 else 0265 $message =
$c->perform_action(); 0266 0267 if($this->_listener !== null) 0268
$this->_listener->after_action_performed($id,$c,$message); 0269 0270 // has an error occurred? 0271
if($message)
/fws/action/performer.php in line 228 [ Method: FWS_Action_Performer::perform_action_by_id() ]
0223 { 0224 $id = $this->get_action_id(); 0225 if($id === null) 0226 return 0; 0227 0228 return
$this->perform_action_by_id($id); 0229 } 0230 0231 /** 0232 * Performs the action with given id, if
available 0233 * 0234 * @param mixed $id the action-id
/fws/document/renderer/html/default.php in line 297 [ Method:
FWS_Action_Performer::perform_action() ]
0292 * Performs the necessary action 0293 * You will find the result in get_action_result() 0294 */
0295 public final function perform_action() 0296 { 0297 $this->_action_result =
$this->_action_perf->perform_action(); 0298 } 0299 0300 /** 0301 * @return the result of the action
in this run. This is: 0302 * <pre> 0303 * -1 = error
/front/src/renderer/html.php in line 309 [ Method:
FWS_Document_Renderer_HTML_Default::perform_action() ]
0304 $a = new $classname($id); 0305 $this->_action_perf->add_action($a); 0306 } 0307 0308 //
perform actions 0309 $this->perform_action(); 0310 0311 0312 // prepare header-templates 0313
$locale = FWS_Props::get()->locale(); 0314 $tpl = FWS_Props::get()->tpl(); 0315 $cfg =
FWS_Props::get()->cfg();
/fws/document/renderer/html/default.php in line 364 [ Method: BS_Front_Renderer_HTML::header() ]
0359 { 0360 $this->before_start(); 0361 0362 // header 0363 if($this->_show_header) 0364
$this->header(); 0365 0366 // content 0367 if($this->_show_content) 0368 { 0369 ob_start(); 0370
$this->content();
/fws/document.php in line 449 [ Method: FWS_Document_Renderer_HTML_Default::render() ]
0444 0445 if($this->_renderer === null) 0446 FWS_Helper::error('Please specify the renderer that
should be used!'); 0447 0448 // render the document 0449 $res = $this->_renderer->render($this);
0450 0451 // send header and return result 0452 $this->_send_header(); 0453 $this->finish(); 0454
0455 // use gzip, if required
/index.php in line 73 [ Method: FWS_Document::render() ]
0068 include_once(BS_PATH.'src/init.php'); 0069 0070 // show the page 0071 $doc = new
BS_Front_Document(); 0072 FWS_Props::get()->set_doc($doc); 0073 echo $doc->render(); 0074 ?>
Show BBCode for the error-message (to post somewhere)

Hoffe mir kann jemand von euch helfen . :roll:
Mfg
Eddy

 
Kein neuer Beitrag Nils , 26.11.2010, 23:22
Beitrag #2   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Hallo,

lade dir mal die aktuelle Version (1.42) herunter. Denn du benutzt ja eine Beta-Version, d.h. eine
Version, die lediglich zum Testen gedacht ist, nicht für einen produktiven Einsatz. Schmeiß die
Beta einfach wieder runter und installier 1.42 neu. Dann sollte der Fehler auch weg sein :)

mfg Nils

 
Kein neuer Beitrag Eddy82 , 27.11.2010, 07:24
Beitrag #3   

IP: n/a
Rang: * * * * * * *
Registrierung: 26.11.2010, 21:18
 

Forum-Gott mit 6 Punkte, 4 Beiträge
Mh ok.

Wir hatten das forum schon mal vor kurzer Zeit im gebrauch.
Da lief es.

Werde es mal Testen hoffe das klappt dann. :-/

 
Kein neuer Beitrag Eddy82 , 28.11.2010, 07:36
Beitrag #4   

IP: n/a
Rang: * * * * * * *
Registrierung: 26.11.2010, 21:18
 

Forum-Gott mit 6 Punkte, 4 Beiträge
Ok mit der anderen Version hat es geklappt.

Jetzt hab ich aber noch mal ne dumme frage. :D

Bin gerade dabei die Farben was anderes zu gestalten so weit ist es auch ok,
aber finde nichts wo ich die dicken Balken ändern kann.

mfg

 
Kein neuer Beitrag Nils , 28.11.2010, 10:48
Beitrag #5   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Eddy82 hat folgendes geschrieben:
Bin gerade dabei die Farben was anderes zu gestalten so weit ist es auch ok,
aber finde nichts wo ich die dicken Balken ändern kann.

Das ist ein Bild. Und zwar themes/default/images/topic.gif. Die Datei müsstest du also austauschen.

mfg Nils

 
Kein neuer Beitrag Eddy82 , 28.11.2010, 21:34
Beitrag #6   

IP: n/a
Rang: * * * * * * *
Registrierung: 26.11.2010, 21:18
 

Forum-Gott mit 6 Punkte, 4 Beiträge
Super muss noch mal ein Dickes DANKE sagen. =)

Druckansicht

n/a n/a 1     (Anzeige: 1 – 6; insgesamt: 6) n/a n/a
User in diesem Thema: 0 Registrierte, 0 Versteckte, 1 Gast, 0 Bots
Keine
Legende: Administratoren, User, Moderatoren
Toggle Ähnliche Themen zu „Fehlermeldung “
  Antworten Aufrufe Themeneröffnung Letzter Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
Thema Fehlermeldungen 9 160315 23.07.2014, 16:16
Von: Mars
18.07.2017, 19:55
Von: Paede Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Fehlermeldung: The profile-field "email" does ... 5 85491 20.10.2013, 22:31
Von: Nico
27.10.2013, 11:50
Von: Nico Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Fehlermeldung nach Update auf 1.4.3 1 15804 23.05.2012, 15:45
Von: Thunderstick
23.05.2012, 17:53
Von: Nils Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  komische fehlermeldung!!! 9 14718 05.02.2012, 12:14
Von: Kevin
12.02.2012, 14:23
Von: Rafioso Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Massenhaft Fehlermeldungen   Seiten 1 2 ] 16 59399 07.09.2010, 13:30
Von: Dieter
09.09.2010, 11:32
Von: Dieter Zum letzten Beitrag
  • 0.179664 Sek., 10 DB-Zugriffe, 1.537 MiB
  • Powered by Boardsolution v1.46