• Willkommen, Gast!
  • Sonntag, 29. März 2020, 04:15:10
Position: Home » Boardsolution » Boardsolution v1.3x » Fatal error: Can not redeclare class
Antworten
Thema: Fatal error: Can not redeclare class [Seite 1 ]

Kein neuer Beitrag ddyh , 05.01.2015, 07:31
Beitrag #1   

IP: n/a
Rang: * * * * * * *
Registrierung: 20.12.2011, 13:26
Wohnort: Esrum, Denmark
 

Forum-Gott mit 23 Punkte, 15 Beiträge
Hello,
I get the following error when I click on Settings (Einstellungen) in admin.

Fatal error: Can not redeclare class BS_ConfigSeparator in
/hsphere/local/home/............/board/acp/src/config_entry.php on line 18

(path is correct, I changed it here)

I have not made some changes, the error is suddenly arisen.

I hope that there are some that can help with this.

Note that I am running with v.3.36 (Yes, I know it is old)

I have PHP version 5.5.29 and MySQL version 5.1.63-community-log

Sincerely, Daniel / ddyh


 
Kein neuer Beitrag Nils , 05.01.2015, 18:07
Beitrag #2   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Hi,

hm...that's weird. I have nearly the same PHP version (that's the only important thing here), i.e.
5.5.12, and it works for me. The error means that the class BS_ConfigSeparator has already been
declared at that point. The reason is probably that the file config_entry.php has already been
included previously. But I don't see how that should happen (provided that you really haven't
changed anything) because it is only included at exactly one location - and even include_once is
used.

I'm afraid I can't help you without getting FTP access so that I can find out what's happening
there. If you want to give me that, please write me a PM.

Best regards,
Nils

 
Kein neuer Beitrag Rafioso , 05.01.2015, 21:04
Beitrag #3   

IP: n/a
Rang: * * * * * * *
Registrierung: 30.08.2006, 22:31
Homepage: http://HomepageStarter.de
Wohnort: O-BW
 

Forum-Gott mit 1723 Punkte, 1537 Beiträge
Hi,

i checked it with php 5.6.3 on Windows now. But it's like in the post above: no problems. Maybe
your webhoster updated to a new version and it's a bug in this version. That's an argument for:

ddyh hat folgendes geschrieben:
I have not made some changes, the error is suddenly arisen.


Best regards
Rafioso

Aktuellste Boardsolution-Version: v1.46
Kommende Boardsolution-Version: TBA
-----------------------------------------------------
Ich erstelle nur noch Modifikationen
für aktuelle Versionen!
-----------------------------------------------------

 
Kein neuer Beitrag ddyh , 06.01.2015, 07:29
Beitrag #4   

IP: n/a
Rang: * * * * * * *
Registrierung: 20.12.2011, 13:26
Wohnort: Esrum, Denmark
 

Forum-Gott mit 23 Punkte, 15 Beiträge
Hi, thanks for your answer.

The fault must lie with my provider, since I have never changed anything in the admin section. I
just tried to replace my files with the original, but I get the same error. Everything else in the
admin section works fine.

I just need to have changed my theme, so I can just do this manually.
Should I change it elsewhere than the sql database, or is this also in a file?

 
Kein neuer Beitrag Nils , 06.01.2015, 09:00
Beitrag #5   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
The adminarea has no theme (if you mean that). If you want to change the theme that you personally
see, you can do that in your profile, i.e. not in the adminarea. In the adminarea you can change
the default theme, though. Which is not possible at the moment because of this problem.

Best regards,
Nils

 
Kein neuer Beitrag ddyh , 06.01.2015, 13:10
Beitrag #6   

IP: n/a
Rang: * * * * * * *
Registrierung: 20.12.2011, 13:26
Wohnort: Esrum, Denmark
 

Forum-Gott mit 23 Punkte, 15 Beiträge
Hi Nils

The main theme I want to change (Christmas theme at this moment)
I can find it in SQL database, but I do not know if I need to change anything else to change the
default theme until I solved the problem.

I have now found that it is probably a problem with my provider because sometimes it works and
sometimes writes error 503

Could it have something to do with the server running PHP 5.3.29 and LiteSpeed.
I have previously read about problems with Joomla after updating the PHP version.

It's just weird that only the config page that makes the problem, and no other pages in the admin
section.

I have also tried to change include_once to require_once, this has not helped.

 
Kein neuer Beitrag Nils , 06.01.2015, 19:32
Beitrag #7   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Hi,

ddyh hat folgendes geschrieben:
The main theme I want to change (Christmas theme at this moment)
I can find it in SQL database, but I do not know if I need to change anything else to change the
default theme until I solved the problem.

Ok, you can change the field "default_forum_style" in bs_config to the id of the theme that should
be used by default. You need to refresh the cache afterwards, though.

ddyh hat folgendes geschrieben:
I have now found that it is probably a problem with my provider because sometimes it works and
sometimes writes error 503

And that happens only for the settings page?

ddyh hat folgendes geschrieben:
Could it have something to do with the server running PHP 5.3.29 and LiteSpeed.
I have previously read about problems with Joomla after updating the PHP version.

I don't know about LiteSpeed. It has potentially something to do with the PHP version, but I still
don't know why the problem occurs, so I' not sure.

ddyh hat folgendes geschrieben:

It's just weird that only the config page that makes the problem, and no other pages in the admin
section.

Definitely, yes.

Best regards,
Nils

 
Kein neuer Beitrag ddyh , 07.01.2015, 07:16
Beitrag #8   

IP: n/a
Rang: * * * * * * *
Registrierung: 20.12.2011, 13:26
Wohnort: Esrum, Denmark
 

Forum-Gott mit 23 Punkte, 15 Beiträge
Hi Nils

Thanks for the quick reply.

I have now solved the problem, which was with the PHP version.

I created a .htaccess file in the root of the webserver with the following code:

Code:
1
AddType application/x-httpd-php54 php


The site now uses PHP version 5.4.36 instead of 5.5.29, and everything works fine now.

Have a nice day

Daniel / ddyh

Abonnieren Druckansicht
Antworten

n/a n/a 1     (Anzeige: 1 – 8; insgesamt: 8) n/a n/a
User in diesem Thema: 0 Registrierte, 0 Versteckte, 1 Gast, 0 Bots
Keine
Legende: Administratoren, User, Moderatoren
Themenaktionen:
Beiträge verschieben

Toggle Ähnliche Themen zu „Fatal error: Can not redeclare class “
  Antworten Aufrufe Themeneröffnung Letzter Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Abfrage, ob User eingeloggt ist / Class 'FWS_ ... 5 116037 16.12.2011, 13:35
Von: PeterD
14.01.2015, 21:40
Von: Rafioso Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Parse error: syntax error, unexpected T_STRIN ... 3 30922 12.04.2013, 21:20
Von: Soccer
28.10.2014, 08:55
Von: zohaa Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Fehlermeldung: The profile-field "email" does ... 5 91312 20.10.2013, 22:31
Von: Nico
27.10.2013, 11:50
Von: Nico Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, verschoben
  fatal error meldung 14 16300 05.10.2012, 18:03
Von: Kevin
20.10.2012, 20:06
Von: Mars Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  error-log 6 12049 13.04.2011, 13:30
Von: Mars
25.12.2011, 18:02
Von: pinsel Zum letzten Beitrag
  • 0.105391 Sek., 10 DB-Zugriffe, 1.573 MiB
  • Powered by Boardsolution v1.46