• Willkommen, Gast!
  • Dienstag, 27. Oktober 2020, 21:42:21
Position: Home » Boardsolution » Boardsolution v1.4x » Umzug von 1.43 auf 1.45
Antworten
Thema: Umzug von 1.43 auf 1.45 [Seite 1 ]

Kein neuer Beitrag othiede , 28.02.2014, 15:50
Beitrag #1   

IP: n/a
Rang: * * * * * * *
Registrierung: 03.03.2008, 14:33
 

Forum-Gott mit 144 Punkte, 98 Beiträge
Guten Tag!

Ich möchte mit einem Board von der Version 1.43 auf einen anderen Hoster umziehen und dabei gleich
auf die aktuelle Version 1.45 aktualisieren.
Was muss ich dabei beachten?

Danke für eure Hilfe.

Herzliche Grüße
Olaf

"Diejenigen, welche grundlegende Freiheiten für ein gewisses Maß an Sicherheit aufgeben würden,
verdienen weder Freiheit noch Sicherheit."
- Benjamin Franklin -

 
Kein neuer Beitrag othiede , 28.02.2014, 18:01
Beitrag #2   

IP: n/a
Rang: * * * * * * *
Registrierung: 03.03.2008, 14:33
 

Forum-Gott mit 144 Punkte, 98 Beiträge
Nun hatte ich erstmal nach der Anleitung im Adminbereich den Umzug angeleiert und diese
Fehlermeldung erhalten:

Fatal error: Class 'FWS_String' not found in
/customers/1/9/7/oldies4ever.org/httpd.www/board/fws/string.php on line 13

Hmm, dachte ich und habe alles wieder gelöscht und die Version 1.43 installationsfähig ein gespielt
und die install.php aufgerufen.

Trotzdem kommt diese Fehlermeldung.
Hat einer einen Rat?
Mit der Hilfe konnte ich hier nichts finden.

Versuche ich 1.45 zu installieren, kommt diese Fehlermeldung:
Fatal error: Class 'FWS_String' not found in
/customers/1/9/7/oldies4ever.org/httpd.www/board/fws/string.php on line 25


PHP Version 5.3.28
safe_mode ist off

Herzliche Grüße
Olaf

"Diejenigen, welche grundlegende Freiheiten für ein gewisses Maß an Sicherheit aufgeben würden,
verdienen weder Freiheit noch Sicherheit."
- Benjamin Franklin -
Dieser Beitrag wurde insgesamt 2 mal editiert. Das letzte Mal 28.02.2014, 21:56 von othiede.

 
Kein neuer Beitrag othiede , 28.02.2014, 22:08
Beitrag #3   

IP: n/a
Rang: * * * * * * *
Registrierung: 03.03.2008, 14:33
 

Forum-Gott mit 144 Punkte, 98 Beiträge
Hat keiner einen Plan?

Herzliche Grüße
Olaf

"Diejenigen, welche grundlegende Freiheiten für ein gewisses Maß an Sicherheit aufgeben würden,
verdienen weder Freiheit noch Sicherheit."
- Benjamin Franklin -

 
Kein neuer Beitrag Rafioso , 01.03.2014, 00:10
Beitrag #4   

IP: n/a
Rang: * * * * * * *
Registrierung: 30.08.2006, 22:31
Homepage: http://HomepageStarter.de
Wohnort: O-BW
 

Forum-Gott mit 1723 Punkte, 1537 Beiträge
Hi,

zunächst einmal muss man natürlich etwas Geduld mit bringen, denn wir machen das hier alles auch
nur während der Freizeit.

Das einzige was du hättest tun müssen, war in der Version 1.43 im Adminbereich den
Versionsvergleich zu starten. Das Archiv entpacken und die Dateien im noconflict-Ordner 1:1 mit den
von v1.43 ersetzen. Anschließend die Dateien im Ordner conflict mit den bereits vorhanden
vergleichen (falls vorhanden) und entsprechend anpassen.

Mehr muss nicht getan werden.

Alternativ kannst du auch einfach die komplette 1.45 Version herunterladen und dann alle Dateien
davon mit der von 1.43 ersetzen, sofern du keine Modifikationen verwendest. Die install.php musst
du dann aber natürlich löschen ;)

MfG
Rafioso

Aktuellste Boardsolution-Version: v1.46
Kommende Boardsolution-Version: TBA
-----------------------------------------------------
Ich erstelle nur noch Modifikationen
für aktuelle Versionen!
-----------------------------------------------------

 
Kein neuer Beitrag Nils , 01.03.2014, 07:34
Beitrag #5   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Hallo,

othiede hat folgendes geschrieben:
Fatal error: Class 'FWS_String' not found in
/customers/1/9/7/oldies4ever.org/httpd.www/board/fws/string.php on line 13

Hmm, dachte ich und habe alles wieder gelöscht und die Version 1.43 installationsfähig ein gespielt
und die install.php aufgerufen.

Trotzdem kommt diese Fehlermeldung.
Hat einer einen Rat?
Mit der Hilfe konnte ich hier nichts finden.

Das ist eigenartig. Wobei das schon einmal vorkam, aber da wurde nicht weiter nach einer Lösung
gesucht, sondern derjenige wollte die 1.3x behalten. Ich würde mir das gerne einmal angucken was da
das Problem ist. Könntest du mir FTP-Zugriff geben? Dann schau ich mal ob ich das rausfinde.

mfg Nils

 
Kein neuer Beitrag othiede , 01.03.2014, 09:47
Beitrag #6   

IP: n/a
Rang: * * * * * * *
Registrierung: 03.03.2008, 14:33
 

Forum-Gott mit 144 Punkte, 98 Beiträge
@Rafioso
Sorry, ich weiß, das ihr alles in der Freizeit macht.
Bin eben ein ungeduldiger Mensch.
Aber schon in der Vergangenheit habt ihr mir immer super geholfen.

Zum Problem:
es ist so, dass ich beim neuen Hoster gar nicht erst weiterkomme. Es erschein sofort nach aufrufen
der URL die Fehlermeldung.
Daher spielte ich die Installation für 1.43 und 1.45 auf.
Rufe ich nun die Installation auf, dann erscheinen die Fehlermeldungen für 1.43 und 1.45
Kannst ja hier schauen:
http://www.oldies4ever.org/board143/install.php
http://www.oldies4ever.org/board145/install.php

@Nils
Schicke dir eine PN

-

Herzliche Grüße
Olaf

"Diejenigen, welche grundlegende Freiheiten für ein gewisses Maß an Sicherheit aufgeben würden,
verdienen weder Freiheit noch Sicherheit."
- Benjamin Franklin -

 
Kein neuer Beitrag Nils , 01.03.2014, 13:52
Beitrag #7   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Hallo,

ok, Problem gefunden. Es liegt tatsächlich einfach nur daran, dass FWS_String in der fws/string.php
benutzt wird bevor die Klasse definiert wurde. Das geht wohl mit den meisten PHP-Versionen, aber
mit deiner nicht. Ich hab das jetzt bei board143 und board145 geändert, so dass die Installation
klappen sollte. Falls noch ein Problem auftritt, sag bitte Bescheid.

mfg Nils
Dieser Beitrag wurde insgesamt 1 mal editiert. Das letzte Mal 01.03.2014, 13:52 von Nils.

 
Kein neuer Beitrag othiede , 01.03.2014, 18:11
Beitrag #8   

IP: n/a
Rang: * * * * * * *
Registrierung: 03.03.2008, 14:33
 

Forum-Gott mit 144 Punkte, 98 Beiträge
Damke Nils.
Ich spiele gerade wieder das Backup vom alten Hoster in Version 1.43 ein.
Wenn das dann läuft will ich das Update auf 1.45 machen.
So wie es Rafiosos weiter oben beschrieben hat.
Geht das aber auch mit dieser PHP Version oder benötige ich da andere Pakete?

Du hast ja anscheinen in unserem Webspace die dort liegenden Versionen 1.45 und 1.43 angepasst an
die PHP-Version dort.
Muss ich die mir runterladen, falls eine komplette neue Installation notwendig ist oder hast du die
Installationspakete, die man sich hier runterladen kann, ebenfalls angepasst?

Wenn ich hier das getestet habe melde ich mich wieder.

Da fällt mir ein, welche Dateien aus der geänderten Version 1.43 muss ich in die Sicherung, die ich
ja nun wieder einspiele, ersetzen? So kommt ja auch nur wieder die Fehlermeldung.

Herzliche Grüße
Olaf

"Diejenigen, welche grundlegende Freiheiten für ein gewisses Maß an Sicherheit aufgeben würden,
verdienen weder Freiheit noch Sicherheit."
- Benjamin Franklin -
Dieser Beitrag wurde insgesamt 1 mal editiert. Das letzte Mal 01.03.2014, 18:15 von othiede.

 
Kein neuer Beitrag Nils , 01.03.2014, 18:36
Beitrag #9   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
othiede hat folgendes geschrieben:
Damke Nils.
Ich spiele gerade wieder das Backup vom alten Hoster in Version 1.43 ein.
Wenn das dann läuft will ich das Update auf 1.45 machen.
So wie es Rafiosos weiter oben beschrieben hat.
Geht das aber auch mit dieser PHP Version oder benötige ich da andere Pakete?

Das sollte gehen, ja. Ohne andere Pakete.

othiede hat folgendes geschrieben:
Du hast ja anscheinen in unserem Webspace die dort liegenden Versionen 1.45 und 1.43 angepasst an
die PHP-Version dort.
Muss ich die mir runterladen, falls eine komplette neue Installation notwendig ist oder hast du die
Installationspakete, die man sich hier runterladen kann, ebenfalls angepasst?

Ne, die Releases auf unserer Webseite habe ich noch nicht angepasst.

othiede hat folgendes geschrieben:
Da fällt mir ein, welche Dateien aus der geänderten Version 1.43 muss ich in die Sicherung, die ich
ja nun wieder einspiele, ersetzen? So kommt ja auch nur wieder die Fehlermeldung.

Ich hab in der fws/string.php folgendes (vom Anfang der Datei):
PHP:
1
2
// set the default value
FWS_String::set_use_mb_functions(function_exists('mb_strlen'));

ans Ende, d.h. vor ?> geschoben.

mfg Nils
Dieser Beitrag wurde insgesamt 1 mal editiert. Das letzte Mal 01.03.2014, 18:37 von Nils.

 
Kein neuer Beitrag othiede , 01.03.2014, 21:15
Beitrag #10   

IP: n/a
Rang: * * * * * * *
Registrierung: 03.03.2008, 14:33
 

Forum-Gott mit 144 Punkte, 98 Beiträge
Danke Nils, läuft wieder alles beim neuen Hoster.

Nur mit der Anleitung für das Update zu 1.45 komme ich überhauptnicht zurecht.

Herzliche Grüße
Olaf

"Diejenigen, welche grundlegende Freiheiten für ein gewisses Maß an Sicherheit aufgeben würden,
verdienen weder Freiheit noch Sicherheit."
- Benjamin Franklin -

 
Kein neuer Beitrag Rafioso , 01.03.2014, 22:36
Beitrag #11   

IP: n/a
Rang: * * * * * * *
Registrierung: 30.08.2006, 22:31
Homepage: http://HomepageStarter.de
Wohnort: O-BW
 

Forum-Gott mit 1723 Punkte, 1537 Beiträge
Hi,

an was scheitert es? Du musst nur die Dateien ersetzen und danach auch noch die Nachrichten im
Adminbereich neu berechnen lassen.

MfG
Rafioso

Aktuellste Boardsolution-Version: v1.46
Kommende Boardsolution-Version: TBA
-----------------------------------------------------
Ich erstelle nur noch Modifikationen
für aktuelle Versionen!
-----------------------------------------------------

 
Kein neuer Beitrag othiede , 03.03.2014, 21:25
Beitrag #12   

IP: n/a
Rang: * * * * * * *
Registrierung: 03.03.2008, 14:33
 

Forum-Gott mit 144 Punkte, 98 Beiträge
Also, ich kopiere die Dateien der Version 1.43, die sich ebenfalls im noconflict Ordner befinden,
von 1.43 in den noconflict Ordner. Dabei die Dateien aus dem 1.43 Installationspaket oder aus der
vorhandenen Installation?

Dann schreibst du weiter:
"Anschließend die Dateien im Ordner conflict mit den bereits vorhanden vergleichen (falls
vorhanden) und entsprechend anpassen."
Wo sollen da Dateien vorhanden sein? In der Installation? Mit welchen Dateien vergleichen? In der
Installation, im noconflict Ordner?

Vielleicht denke ich auch nur schräg.

Herzliche Grüße
Olaf

"Diejenigen, welche grundlegende Freiheiten für ein gewisses Maß an Sicherheit aufgeben würden,
verdienen weder Freiheit noch Sicherheit."
- Benjamin Franklin -

 
Kein neuer Beitrag Rafioso , 03.03.2014, 21:58
Beitrag #13   

IP: n/a
Rang: * * * * * * *
Registrierung: 30.08.2006, 22:31
Homepage: http://HomepageStarter.de
Wohnort: O-BW
 

Forum-Gott mit 1723 Punkte, 1537 Beiträge
Guten Abend,

ich denke du machst das zu umständlich.

Wenn ich dich richtig verstanden habe, dann läuft bei dir aktuell die Version 1.43. Gehe dann in
den Adminbereich und mache einen Versionsvergleich zu 1.45 und lade dann das Archiv herunter.

Solltest du in der Version 1.43 bereits etwas geändert habe, wird das Archiv zwei "Hauptordner"
enthalten. Einmal noconflict und einmal conflict.

Alle Dateien, die im Ordner noconflict sind, können einfach mit den Dateien der aktuell laufenden
1.43 Version ersetzt werden.

Alle Dateien, die im Ordner conflict sind, weisen Unstimmigkeiten auf, weil du z.B. in der Version
1.43 an dieser Datei irgendetwas geändert hast. Darum musst du die Datei aus dem conflict-Ordner
mit der Datei von deiner 1.43 Installation vergleichen (Diff-Viewer) und die Änderungen überprüfen
und übernehmen. Anschließend musst du auch diese Dateien mit denen, der aktuell laufenden 1.43
Version ersetzen.

Ich hoffe, das war jetzt ausführlicher.

MfG
Rafioso

Aktuellste Boardsolution-Version: v1.46
Kommende Boardsolution-Version: TBA
-----------------------------------------------------
Ich erstelle nur noch Modifikationen
für aktuelle Versionen!
-----------------------------------------------------

Abonnieren Druckansicht
Antworten

n/a n/a 1     (Anzeige: 1 – 13; insgesamt: 13) n/a n/a
User in diesem Thema: 0 Registrierte, 0 Versteckte, 1 Gast, 0 Bots
Keine
Legende: Administratoren, User, Moderatoren
Themenaktionen:
Beiträge verschieben

Toggle Ähnliche Themen zu „Umzug von 1.43 auf 1.45“
  Antworten Aufrufe Themeneröffnung Letzter Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
Thema Hostingumzug   Seiten 1 2 3 4 5 ] 61 100963 23.04.2008, 01:50
Von: sandyneedsmusic
07.04.2013, 00:27
Von: sandyneedsmusic Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Mailversand nach Board-Umzug 4 12534 26.02.2013, 20:02
Von: othiede
26.02.2013, 22:07
Von: othiede Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Serverumzug => Admin Hilfe 4 13952 25.03.2011, 06:33
Von: Mars
25.03.2011, 13:12
Von: Mars Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Kann mich nach einem Serverumzug nicht mehr i ... 2 11073 13.12.2010, 14:16
Von: pcdoc
13.12.2010, 18:11
Von: pcdoc Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
Thema Ich komme nach Serverumzug nicht mehr in den ... 8 21041 08.11.2010, 07:38
Von: Speedi
13.12.2010, 09:43
Von: Speedi Zum letzten Beitrag
  • 0.030966 Sek., 10 DB-Zugriffe, 1,006.813 KiB
  • Powered by Boardsolution v1.46