• Willkommen, Gast!
  • Dienstag, 27. Oktober 2020, 22:28:00
Position: Home » Boardsolution » Boardsolution v1.2x und älter » Fehlermeldung nach Datenbankimport
Antworten
Thema: Fehlermeldung nach Datenbankimport [Seite 1 ]

Kein neuer Beitrag x-over , 20.05.2007, 21:24
Beitrag #1   

IP: n/a
Rang: * * * * * * *
Registrierung: 27.02.2007, 19:01
 

Forum-Gott mit 31 Punkte, 19 Beiträge
Hallo

Ich habe die Datenbank via phpmyadmin gespeichert, gelöscht und wieder importiert. Nun habe ich
folgende fehlermeldung:

Code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
unserialize() [function.unserialize]: Error at offset 4480 of 6378 bytes
Call-trace: 

/home/httpd/vhosts/woeti.ch/httpdocs/picturesolution/community/src/db_cache.php in line 71 [Function: unserialize()] 
0066       {
0067           $this->_cache_content = array();
0068           if(is_array($content))
0069               $this->_cache_content = $content;
0070           else if($content)

0071               $this->_cache_content = unserialize($content);

0072   
0073           $this->_length = count($this->_cache_content);
0074           $this->_cache_content_keys = array_keys($this->_cache_content);
0075       }
0076   
0077       /**

/home/httpd/vhosts/woeti.ch/httpdocs/picturesolution/community/src/db_cache.php in line 29 [Method: BS_db_cache::set_content()] 
0024       function BS_db_cache($table_name,$cache_key,$cache_content = '',$array_key = '')
0025       {
0026           $this->_table_name = $table_name;
0027           $this->_cache_key = $cache_key;
0028           $this->_array_key = $array_key;

0029           $this->set_content($cache_content);

0030       }
0031   
0032       /**
0033        * @param string $query the SQL-query for the cache
0034        * @access public
0035        */

/home/httpd/vhosts/woeti.ch/httpdocs/picturesolution/community/src/cache_container.php in line 143 [Method: BS_db_cache::BS_db_cache()] 
0138               case 'languages':
0139               case 'intern':
0140               case 'user_fields':
0141               case 'user_groups':
0142               case 'tasks':

0143                   $this->_cache_obj[$name] = new BS_db_cache($table_name,$name,$this->_cache_data[$name],'id');

0144                   break;
0145   
0146               // default init
0147               default:
0148                   $this->_cache_obj[$name] = new BS_db_cache($table_name,$name,$this->_cache_data[$name]);
0149                   break;

/home/httpd/vhosts/woeti.ch/httpdocs/picturesolution/community/src/cache_container.php in line 51 [Method: BS_CacheContainer::_init_object()] 
0046   
0047           if(!$this->_initialized)
0048               $this->_init_cache();
0049   
0050           if(!isset($this->_cache_obj[$name]))

0051               $this->_init_object($name);

0052   
0053           return $this->_cache_obj[$name];
0054       }
0055   
0056       /**
0057        * returns the cache-content of the given name (the table-name)

/home/httpd/vhosts/woeti.ch/httpdocs/picturesolution/community/src/additional_fields.php in line 13 [Method: BS_CacheContainer::get_cache()] 
0008        * constructor
0009        */
0010       function BS_additional_fields()
0011       {
0012           global $CACHECON;

0013           $this->_cache = &$CACHECON->get_cache('user_fields');

0014       }
0015   
0016       /**
0017        * @return object a reference to the internal cache-object
0018        */
0019       function &get_cache()

/home/httpd/vhosts/woeti.ch/httpdocs/picturesolution/community/index.php in line 137 [Method: BS_additional_fields::BS_additional_fields()] 
Wie kann ich diesen Fehler beheben?

vielen dank für eure mithilfe
Dieser Beitrag wurde insgesamt 1 mal editiert. Das letzte Mal 20.05.2007, 21:28 von Nils.

 
Kein neuer Beitrag Nils , 20.05.2007, 21:34
Beitrag #2   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Hallo,

hm..vllt. ist da irgendwas mit dem Zeichensatz schiefgelaufen oder so.

Das blöde ist natürlich, dass du so nicht so einfach in den Adminbereich kommst um das korrigieren
zu können. Ich glaube das einfachste ist, wenn du das mit einer kleinen Änderung im PHP-Code
machst. Füg mal folgendes unter Zeile 126 der index.php ein:
Code:
1
2
3
4
5
6
7
8
9
10
$cfg_c = &$CACHECON->get_cache('config');
$cfg_c->regenerate_cache(true);
$LANGS->regenerate_cache(true);
$THEMES ->regenerate_cache(true);
$BANS->regenerate_cache(true);
$INTERN->regenerate_cache(true);
$SMILEYS->regenerate_cache(true);
$RANKS->regenerate_cache(true);
$BADWORDS->regenerate_cache(true);
$ACP_ACCESS->regenerate_cache(true);
Dann einmal das Forum (index) aufrufen. Danach müsste es erstmal wieder gehen. Geh aber gleich in
den Adminbereich und aktualisier alle DB-Cache-Einträge!
Und natürlich den Kram aus der index.php wieder rausnehmen ;-)

mfg Nils

 
Kein neuer Beitrag x-over , 21.05.2007, 18:51
Beitrag #3   

IP: n/a
Rang: * * * * * * *
Registrierung: 27.02.2007, 19:01
 

Forum-Gott mit 31 Punkte, 19 Beiträge
Hat geklapt!

Vielen vielen Dank für die Hilfe!

Das Forum hats trotz fehlermeldung angezeigt. Ich musste also lediglich den DB-Cache aktualisieren.

Gruss


Abonnieren Druckansicht
Antworten

n/a n/a 1     (Anzeige: 1 – 3; insgesamt: 3) n/a n/a
User in diesem Thema: 0 Registrierte, 0 Versteckte, 1 Gast, 0 Bots
Keine
Legende: Administratoren, User, Moderatoren
Themenaktionen:
Beiträge verschieben

Toggle Ähnliche Themen zu „Fehlermeldung nach Datenbankimport“
  Antworten Aufrufe Themeneröffnung Letzter Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
Thema Fehlermeldungen 9 185591 23.07.2014, 16:16
Von: Mars
18.07.2017, 19:55
Von: Paede Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Fehlermeldung: The profile-field "email" does ... 5 93719 20.10.2013, 22:31
Von: Nico
27.10.2013, 11:50
Von: Nico Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Fehlermeldung nach Update auf 1.4.3 1 17277 23.05.2012, 15:45
Von: Thunderstick
23.05.2012, 17:53
Von: Nils Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  komische fehlermeldung!!! 9 15593 05.02.2012, 12:14
Von: Kevin
12.02.2012, 14:23
Von: Rafioso Zum letzten Beitrag
Keine neuen Beiträge, nicht wichtig Keine neuen Beiträge, „heißes Thema“
Keine neuen Beiträge, offen Keine neuen Beiträge, nicht verschoben
  Fehlermeldung 5 167359 26.11.2010, 21:38
Von: Eddy82
28.11.2010, 21:34
Von: Eddy82 Zum letzten Beitrag
  • 0.026892 Sek., 10 DB-Zugriffe, 868.070 KiB
  • Powered by Boardsolution v1.46