• Willkommen, Gast!
  • Montag, 01. Juni 2020, 17:36:33
Position: Home » Boardsolution » Boardsolution v1.3x » Hostingumzug

Information

Fehler: Du musst Dich erst registrieren und einloggen!

Antworten
Thema: Hostingumzug [Seite 1 2 3 5 ]

Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 01:50
Beitrag #1   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
ich hoffe es ist okay, dass ich hier nachfrage.... naja, das Forum selbst hat ja schon eine BackUp
Funktion.... nur scheint es mir damit nicht zu gehen, wenn ich mein Hosting gewechselt hab, eine
Neuinstallation durchführ und dann das BackUp in den Ordner "backups" reinkopier und auf
DB-Sicherung geh, um da dann ein BackUp durchzuführen??
und mit den ganzen verschiedenen Optionen für DB-Export im MyPHP bin ich irgendwie echt
überfordert..... :cry:

 
Kein neuer Beitrag Nils , 23.04.2008, 09:40
Beitrag #2   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Hallo,

machs einfach folgendermaßen:

  • Erstell mit dem Backup-Script von BS auf deinem jetzigen Server ein Backup von allem
  • Installier BS auf dem neuen Server neu (wähl hierbei das gleiche Tabellenpräfix)
  • Ruf dort das Backup-Script auf und importier das auf dem anderen Server erstellte Backup in die
    Datenbank, wobei die alten Tabellen überschrieben werden.

Das wars :)

Allerdings solltest du noch den Cookie-Pfad und die Cookie-Domain im Adminbereich für den neuen
Server umstellen.

mfg Nils
Dieser Beitrag wurde insgesamt 1 mal editiert. Das letzte Mal 23.04.2008, 09:40 von Nils.

 
Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 10:24
Beitrag #3   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
hmm..... so hab ich das gestern schon mal versucht.... da kam dann glaub irgendwie so'n Fehler von
wegen UTF-8...
ich weiss nur nicht mehr genau was..... ich versuch es einfach jetzt nochmal genau so und poste
dann die Fehlmeldung, falls sie wieder kommt. ;)

ähm.... hab ich jetzt aber richtig verstanden, über die BackUp Funktion im Forum, nicht direkt in
der DB, oder?
Dieser Beitrag wurde insgesamt 1 mal editiert. Das letzte Mal 23.04.2008, 10:32 von sandyneedsmusic.

 
Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 10:57
Beitrag #4   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
Cannot modify header information - headers already sent by (output started at
/home/www/web422/html/forum/src/debug.php:177)

Call-trace:

  • /home/www/web422/html/forum/src/functions.php in line 98
    [ Function: setcookie() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0093       */
    0094      function set_cookie($name,$value,$lifetime = BS_COOKIE_LIFETIME)
    0095      {
    0096         $this->input->set_var(BS_COOKIE_PREFIX.$name,'cookie',$value);
    0097         setcookie(BS_COOKIE_PREFIX.$name,$value,time() + $lifetime,
    0098                        $this->cfg['cookie_path'],$this->cfg['cookie_domain']);
    0099      }
    0100      
    0101      /**
    0102       * deletes the cookie with given name
    0103       *
    0104       * @param string $name the name of the cookie (without BS_COOKIE_PREFIX)

  • /home/www/web422/html/forum/src/auth/session.php in line 552
    [ Method: bs_functions::set_cookie() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0547        // if no session-id exists or the session-id is invalid (not in the online-table)
    0548        // we have to generate a new one
    0549        if($session_id == '' || !isset($this->_online_table[$session_id]))
    0550        {
    0551           $session_id = $this->_generate_session_id();
    0552           $this->functions->set_cookie('sid',$session_id);
    0553        }
    0554   
    0555       $this->_set_session_id($session_id);
    0556   
    0557       $this->_user_agent = $this->input->get_var('HTTP_USER_AGENT','server',BS_STRING);
    0558       $this->_bot_name = $this->_get_bot_name($this->_user_agent,$this->user_ip);

  • /home/www/web422/html/forum/src/auth/session.php in line 154
    [ Method: bs_user::_init_session() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0149      * @access public
    0150      */
    0151     function init_session()
    0152     {
    0153        $this->_generate_session_table();
    0154        $this->_init_session();
    0155       $this->_logout_offline_user();
    0156   
    0157         // login by cookie?
    0158       if(!$this->_admin_required && !$this->is_loggedin())
    0159       {
    0160          $user = $this->input->get_var(BS_COOKIE_PREFIX.'user','cookie',BS_STRING);

  • /home/www/web422/html/forum/src/auth/user.php in line 78
    [ Method: bs_user::init_session() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0073       * 
    0074       * @access public
    0075       */
    0076      function init()
    0077      {
    0078         $this->init_session();
    0079         
    0080         $this->_calculate_forum_lang();
    0081         $this->_calculate_forum_theme();
    0082         $this->_calculate_timezone();
    0083   
    0084         $time = time();

  • /home/www/web422/html/forum/src/base.php in line 352
    [ Method: bs_user::init() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0347            BS_add_objects_to_class($this,$this->$name);
    0348         
    0349         // init the session
    0350         if($this->_config['sess'])
    0351         {
    0352            $this->sess->init();
    0353            $this->auth->init();
    0354            if($this->_config['unread'])
    0355               $this->unread->init();
    0356         }
    0357   
    0358         // init language

  • /home/www/web422/html/forum/src/base.php in line 225
    [ Method: bs_acp_base::_init() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0220         {
    0221            if(isset($this->_config[$val]))
    0222               $this->_config[$val] = false;
    0223         }
    0224   
    0225         $this->_init($admin_required);
    0226      }
    0227   
    0228      /**
    0229       * inits all necessary stuff
    0230       *
    0231       * @param boolean $admin_required for the session: is an admin required to login?

  • /home/www/web422/html/forum/acp/src/acp_base.php in line 38
    [ Method: bs_base::bs_base() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0033       * @param array $exclude the objects to exclude from loading
    0034       * @access public
    0035       */
    0036      function BS_ACP_Base($path,$show_menu,$exclude = array())
    0037      {
    0038         BS_Base::BS_Base($path,$exclude,true);
    0039         
    0040         include_once($this->path.'acp/src/acp.php');
    0041         $this->acp = new BS_ACP($this,$show_menu);
    0042         
    0043         $this->functions->include_language_file('lang_admin.php');
    0044         

  • /home/www/web422/html/forum/acp/pages/frameset.php in line 28
    [ Method: bs_acp_base::bs_acp_base() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0023       */
    0024      function BS_ACP_Page_frameset($path = '')
    0025      {
    0026         $this->_module = new BS_ACP_Base($path,false,array(
    0027            'sql_helper','url'
    0028         ));
    0029      }
    0030      
    0031      function display()
    0032      {
    0033         $this->start();
    0034         

  • /home/www/web422/html/forum/admin.php in line 32
    [ Method: bs_acp_page_frameset::bs_acp_page_frameset() ]
    Code:
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    0027   {
    0028      include_once($bspath.'acp/pages/'.$page.'.php');
    0029      $class = 'BS_ACP_Page_'.$page;
    0030      if(class_exists($class))
    0031      {
    0032         $c = new $class($bspath);
    0033         $c->display();
    0034      }
    0035   }
    0036   ?>


 
Kein neuer Beitrag Nils , 23.04.2008, 13:41
Beitrag #5   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Das ist bestimmt nicht die erste Meldung, die angezeigt wird, oder? :)
Zeig mal die erste. Der Rest sind oft Folgefehler...

mfg Nils

 
Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 13:44
Beitrag #6   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
ich hab jetzt nochmal ganz neu installiert, mir davon auch ein BackUp gemacht, falls das
wiederherstellen das anderen wieder schief läuft.... hab so schiss... :roll:

gut, ich wag's jetzt nochmal und editiere die Meldung dann gleich hier rein.... ich hab
schisssss.... :-P :confused:


ach, da kommen so viele Fehler.... kannst Du hier selbst sehen, oder?
http://www.mutismus.ch/forum :-/
Dieser Beitrag wurde insgesamt 2 mal editiert. Das letzte Mal 23.04.2008, 13:46 von sandyneedsmusic.

 
Kein neuer Beitrag Nils , 23.04.2008, 14:09
Beitrag #7   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Ok, vermutlich haben die Datenbanken der beiden Hoster unterschiedliche Zeichensätze.

Mach mal folgendes: Öffne die src/page.php und füg unter Zeile 51:
Code:
1
$this->_module->functions->start_document();

folgendes ein:
Code:
1
$this->_module->cache->regenerate_caches();

Dann ruf das Board einmal auf, nimm die Zeile danach wieder raus, und ruf es nochmal auf. Dann
sollte es wieder gehen.

mfg Nils

 
Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 14:18
Beitrag #8   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
hmm.... da kam dann: Fatal error: Call to a member function on a non-object in
/home/www/web422/html/forum/src/page.php on line 51

und die Meldungen waren und sind immer noch da... :-/

 
Kein neuer Beitrag Nils , 23.04.2008, 14:21
Beitrag #9   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Oh, sorry, ich meinte:
Code:
1
$this->_module->cachecon->regenerate_caches();


mfg Nils

 
Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 14:29
Beitrag #10   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
http://www.cosgan.de/images/midi/froehlich/b020.gif geht!

nur einige Forenbeschreibungen sind gerade nicht vollständig, aber das ja nicht schlimm.... mal
gucken, ob sonst alles geht... hatte nämlich auf dem anderen Hosting so kleinere Problemchen, was
aber wahrscheinlich davon kam, dass ich auch mal die Board-URL gewechselt hatte oder so.... :-P ich
teste jetzt mal bisschen rum... aber die User und Beiträge scheien da zu sein... ;)

 
Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 15:03
Beitrag #11   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
:cry: wenn ich auf 'n Thema klickt, will der die index.php DOWNLOADEN!? :shock:

 
Kein neuer Beitrag Nils , 23.04.2008, 17:42
Beitrag #12   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
hm...könntest du mir mal Admin- und FTP-Zugriff bei dir geben? Ich glaube ohne das näher
untersuchen zu können finde ich nicht raus was das ist.

mfg Nils

 
Kein neuer Beitrag sandyneedsmusic , 23.04.2008, 18:02
Beitrag #13   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
okay, Danke, hast PN ;)

 
Kein neuer Beitrag Nils , 23.04.2008, 18:38
Beitrag #14   

IP: n/a
Rang: * * * * * * *
Registrierung: 01.07.2003, 18:55
Homepage: http://www.script-solution.de
Wohnort: Marburg
 

Forum-Gott mit 7812 Punkte, 7566 Beiträge
Habe mir das nun mal angeguckt. Ehrlich gesagt habe ich keine Ahnung was genau da das Problem ist :/
Ich tippe in Richtung zu wenig Speicher für PHP. Aber überprüfen kann ich das nicht, da deine
PHP-Version das dafür nötige nicht dabei hat. Nur das Limit ist 8MB, was eigentlich reichen sollte.
Insofern macht das auch nicht wirklich Sinn. Vielleicht ist es auch ein Fehler in der PHP-Version...

Auf jeden Fall habe ich mal die ähnlichen Themen deaktiviert. Dadurch klappt es jetzt. Aber wenn es
wirklich ein Speicher-Problem ist, dann müsste das eigentlich auch woanders auftreten...

mfg Nils

Edit: Auf jeden Fall stimmt bei der GD-Library, die bei dir installiert ist, etwas nicht (siehe das
Bild bei der Statistik). Vielleicht könntest du bei deinem Hoster nachfragen ob ein Update auf PHP5
und auch eine neuere GD-Version in Frage kommt?

Edit2: Achja, die abgeschnittenen Beiträge. Auch ne gute Frage was da schief gelaufen ist.
Vermutlich liegt das am Zeichensatz in der Datenbank. Aber das sind ja nicht so viele, so dass du
die selbst wiederherstellen könntest :)
Dieser Beitrag wurde insgesamt 2 mal editiert. Das letzte Mal 23.04.2008, 18:42 von Nils.

 
Kein neuer Beitrag sandyneedsmusic , 23.05.2008, 15:43
Beitrag #15   

IP: n/a
Rang: * * * * * * *
Registrierung: 28.04.2007, 12:06
 

Forum-Gott mit 120 Punkte, 98 Beiträge
wie hast das denn nun hinbekommen, dass es funktioniert, dass das Ding bei klick nicht mehr die
index.php downloaden will...? hab dasselbe Problem nämlich gerade wieder mit einem neu installieren
Forum... :-/

Abonnieren Druckansicht
Antworten

n/a n/a 1 2 3 5     (Anzeige: 1 – 15; insgesamt: 62) Weiter Letzte Seite
User in diesem Thema: 0 Registrierte, 0 Versteckte, 1 Gast, 0 Bots
Keine
Legende: Administratoren, User, Moderatoren
Themenaktionen:
Beiträge verschieben

Toggle Ähnliche Themen zu „Hostingumzug“
  Antworten Aufrufe Themeneröffnung Letzter Beitrag
Es wurden keine Themen gefunden.
  • 0.115738 Sek., 11 DB-Zugriffe, 1.791 MiB
  • Powered by Boardsolution v1.46